Error: endpoint is required